﻿# Email settings

> [HTML Version](email-settings.html)

Connect corporate email so that users can receive emails on behalf of the company about new tasks or business processes.

You can configure the sending messages with any content in business processes using the [Email Notification](360011443400.md) activity.

Moreover, in their [profiles](360016398552.md#task-alerts) users can enable email notifications about new approval tasks and make it possible to approve and reject files directly from emails.

Please note that in BRIX On-Premises you have to additionally set up sending out invites to new users, password recovery emails, and new task notifications. To do that, [edit the configuration file](#enable-smtp-server).

````
начало внимание

````
Only users included in the [Administrators](360006871932.md) group can manage email settings. 

````
конец внимание````
 

To configure email settings, do the following:

1. Go to **Administration > System Settings > Email Settings**.

**(email_stngs_1.PNG)**

2. In the **Service** field, select one of the available mailing services:

- **gmail.com**

- **yahoo.com**

- **outlook.com**

- **office365.com**

- **Other**. Enter the address of your SMTP server. You can configure only one SMTP server at a time. Specify the outgoing emails protocol parameters and the port to use: 25, 465, or 587. You can also enable additional options:  
**(email-settings-2.png)**

	- **Send from Reply-to address**. Allows you to change the default sender address for emails sent using the **Email Notification** block. If the field with the sender’s email is not filled in the [settings of this block](360011443400.md#sender-address), the value you specify below in the **Login\*** field will be applied. To apply another address instead of this default address, enable the **Send from Reply‑to address** option and fill in the **Default reply address** field that appears below. Then the value of this field will be used if the sender’s address is not specified in the block settings.

	- **Use TLS**. Check this box if the mailing service transfers data via an encrypted connection.

3. In the **Login\*** field, specify the corporate email address that messages will be sent from. Then enter the password for this email. Also, the value of the **Login\*** field is used as the default sender’s address for emails sent using the [Email Notification](360011443400.md#sender-address) block.

4. The gmail.com, yahoo.com, outlook.com, and office365.com mailing services require two-step authentication and an app password:

- **gmail.com**. In the account settings, enable two-step authentication. Then [create an app password](https://myaccount.google.com/u/0/security). Read more in the [official Google documentation](https://support.google.com/accounts/answer/185833?hl=en).

- **yahoo.com**. In the [account settings](https://login.yahoo.com/account/security), create an app password and use it to establish connection.

- **outlook.com** and **office365.com**. Go to [advanced security options](https://account.microsoft.com/security/) and enable two-step verification, then go to **App passwords** and create a new password. Read more about the settings in the [official Microsoft documentation](https://support.microsoft.com/en-us/account-billing/manage-app-passwords-for-two-step-verification-d6dc8c6d-4bf7-4851-ad95-6d07799387e9).

The table below lists possible errors that may appear when checking the connection if additional verification is disabled.

Possible errors

| | |
|------|------|
| **Possible errors** | **Solution** |
| **Gmail.com** | 
| \[1\] org.apache.commons.mail.EmailException: Sending the email to the following server failed : smtp.Gmail.com:587<br>\[2\] 535-5.7.8 Username and Password not accepted. Learn more at 535 5.7.8 https://support.google.com/mail/?p=BadCredentials c21sm18730030qkm.8 - gsmtp<br>\[3\] 530 5.7.0 Must issue a STARTTLS command first. x14sm29391461qtc.44 - gsmtp<br>\[4\] 534-5.7.14 Please log in via your web browser and 534-5.7.14 then try again. 534-5.7.14 Learn more at 534 5.7.14 https://support.google.com/mail/answer/78754 hw7sm51688135pac.12 - gsmtp |  <br> In the account settings, enable two-step authentication, [create an app password](https://myaccount.google.com/u/0/security), and use it to establish connection.<br>  |
| **Yahoo.com** | 
| \[1\] Sending the email to the following server failed : smtp.mail.yahoo.com:587<br>\[2\] 535 5.7.0 (#AUTH005) Too many bad auth attempts. | Go to [account settings](https://login.yahoo.com/account/security), create an app password, and use it to establish connection. |
|  **Outlook** **and Office365** | 
| Go to [advanced security options](https://account.microsoft.com/security/), enable two-step verification, then go to **App passwords** and create a new password. | 

5. Save the settings and make sure the connection has been successfully established. To do that, click **Test Connection**. Note that the message for confirming your details will be sent to the email specified in your user profile, not to the address that you have entered as the **Login\***.

6. In BRIX On-Premises, additionally configure the connection to the SMTP server. It will be used for sending invitations to new users, password recovery, and sending [notifications about new tasks](360016398552.md#notification). 

To configure, follow these steps:

- Set and apply the SMTP server connection parameters in the \[OBJECT\] file. For more details, read the [Modify BRIX parameters](change-settings-enterprise.md#connect-smtp-server) article.